34 lines
801 B
Plaintext
34 lines
801 B
Plaintext
# Contributor:
|
|
# Maintainer:
|
|
pkgname=hs9001
|
|
pkgver=0.5
|
|
pkgrel=0
|
|
pkgdesc="Bash history put into sqlite so it can be searched "
|
|
url="https://github.com/quitesimpleorg/hs9001"
|
|
arch="all"
|
|
license="MIT"
|
|
depends=""
|
|
makedepends="go"
|
|
source="${pkgname}-${pkgver}.tar.gz::https://github.com/quitesimpleorg/hs9001/archive/refs/tags/v$pkgver.tar.gz"
|
|
builddir="$srcdir/hs9001-${pkgver}"
|
|
|
|
build() {
|
|
# Replace with proper build command(s)
|
|
cd "$builddir"
|
|
go build -ldflags "-s -w"
|
|
:
|
|
}
|
|
|
|
check() {
|
|
# Replace with proper check command(s)
|
|
:
|
|
}
|
|
|
|
package() {
|
|
# Replace with proper package command(s)
|
|
install -m 755 hs9001 -D $pkgdir/usr/bin/hs9001
|
|
:
|
|
}
|
|
|
|
sha512sums="eaed2b7646d6c246c4de779074dc3346b246e666ddb29073293f12c9ee1ce99604d948773ddf9846a65f87c3b9e1308884952edb973cae0cb866b57295a8d4fb hs9001-0.5.tar.gz"
|